Debian и Broadcom Extreme II

После установки debian на сервере не поднялись две интегрированные сетевые карты — broadcom extreme II. После разбирательств выяснилось, что для запуска этих сетевых нужен firmware, которого нет в стандартной установке, но есть в репозиториях non-free. Что нужно сделать:

  1. добавить закрытый репозиторий (non-free)

    deb http://ftp.debian.org/debian/ squeeze main contrib non-free
    deb-src http://ftp.debian.org/debian/ squeeze main contrib non-free
  2. обновить репозиторий

    apt-get update
  3. установить нужный firmware, в нашем случае это bnx2

    apt-get install bnx2
  4. затем перезагрузиться и можно пользоваться

Обсуждение

Ваш комментарий:
  _____  ____    __ __  _      __   __ __  _   __
 / ___/ / __ \  / // / | | /| / /  / //_/ | | / /
/ (_ / / /_/ / / _  /  | |/ |/ /  / ,<    | |/ / 
\___/  \____/ /_//_/   |__/|__/  /_/|_|   |___/